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1- Introduction : 
 

ORCAD LAYOUT dispose de toutes les fonctionnalités pour créer des fichiers en vue de la fabrication d’une 
carte électronique. Les fichiers créés permettent de : 

 fabriquer le circuit imprimé (plans des pistes sur les différentes couches, plans de sérigraphie, plan de 
perçage, etc.) 

 monter automatiquement les composants 

 
La réalisation d’un circuit imprimé peut se décomposer en différentes étapes : 
 

 La saisie du schéma sous Orcad Capture,  

 La recherche et la saisie des Empreintes (Footprints),  

 La mesure des dimensions de la carte, 

 Le Placement des composants , 

 Le Routage des Pistes en respect des contraintes,  

 Vérifications avant impression du typon pour réalisation, 

 Soudure des composants sur la carte,  

 Essais de fonctionnement de la carte. 
 
Fichiers et flux de conception avec LAYOUT : 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
On saisit le schéma sous Orcad Capture, à l’aide de symboles qui sont contenus, dans des librairies que l’on 
chargera à volonté et suivant les besoins. 
Une fois le schéma fini et vérifié, on crée la Netlist. C’est le fichier que l’on va charger sous Orcad Layout pour 
faire le typon en liaison avec Orcad Capture. Il faut donc que le schéma soit correct ! 
En chargeant la netlist, Orcad Layout va chercher les empreintes (FootPrints) dans les librairies et affiche le « 
chevelu », c'est-à-dire les empreintes reliées par des fils. 

 

Logiciel Capture : 
*.opj (projet) 
*.dsn (dessin) 
*.dbk (librairie) 
*.mnl (netlist) 
*.bom (liste des composants) 

 
Logiciel Layout Plus : 
*.max (carte) 
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Il faut alors tracer le contour de la carte, placer les composants, et les router. 
Il restera alors à sortir les faces sur papier calque pour pouvoir les tirer sur circuits imprimés. 
 
 

2- LES NOTIONS CLÉS DE LAYOUT 
 

Une carte électronique est composée de composants soudés sur la carte sur des pastilles et interconnectés 
avec des pistes de cuivre. Les différentes informations concernant les composants, les pistes, les pastilles, les 
trous de perçage, etc. sont disposées sur des couches (layers). 
 
Les différents éléments (ou objets) d’un circuit imprimé sont regroupés en catégories dans Layout : 

 les composants 

 les pastilles 

 les obstacles 

 les connexions 

 les pistes (représentation physique des connexions) 

 du texte 

 etc. 
 
exemple de circuit imprimé généré avec les outils de Layout : 
 

 
 
Les principales couches de layout : 
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 LES TABLEAUX (SPREADSHEET) 
 
Layout possède de nombreuses possibilités pour la configuration et une très grande souplesse pour la 
modification des paramètres. Outre les boîtes de dialogues habituelles, Layout dispose de nombreux tableaux 
dans lesquels sont regroupées les informations par catégories présentées plus haut. 
Les principaux tableaux de Layout sont décrits ci-dessous : 
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Icones 

 
L’ensemble des icones de Layout est résumé sur ce schéma global.  
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3- Procédure de réalisation d’un circuit imprimé 
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3.1-  Saisie du schéma : 
 
Lancer Orcad Capture et créer un nouveau projet en choisissant le type PC Board Wizard 
 

 

 
Réaliser alors la saisie du schéma du montage à réaliser puis appliquer une vérification des règles électriques 
avec la commande DRC. 

 
 

3.2-  Liste des composants 
 
Vous pouvez aussi obtenir la liste des composants du montage en faisant Tools -> Bill of material. Un nouveau 
fichier avec l’extension BOM, contenant la liste des composants est mis dans le projet : 
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Il suffit de double cliquer dessus pour l’ouvrir, et l’imprimer si besoin. 
 

 
 

3.3- Recherche et Assignations des empreintes : 
 
Ré ouvrir la page schéma puis faire Edit -> Select All (ou Ctrl A), puis Edit Properties (Ctrl E). La fenêtre des 
propriétés s’ouvre, choisir alors le filtre par Capture (Filter by Capture), et l’onglet Parts. On obtient alors la 
fenêtre ci-dessous : 
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On va s’intéresser à la colonne PCB Footprint ( empreinte physique ) , si il y a des cases de déjà remplies, les 
effacer, car le choix par défaut n’est surement pas bon ! 
Il reste maintenant à se procurer les composants réels pour connaître leur forme, et alors faire l’association des 
empreintes aux symboles. 
Cette étape est importante, car une même référence de composants, peut avoir plusieurs formes différentes. 
Une fois les composants sous les yeux, on peut alors rechercher leur FOOTPRINT dans le Library Manager de 
Layout. 

 
A partir du meu Demarrer -> Tous les Programmes -> Orcad Release 9.1 -> Layout. Lancer le programme 
LAYOUT. Une fenêtre Orcad Layout s’ouvre, on choisit alors le menu Tools -> Library Manager : 
 

 
Une nouvelle fenêtre s’ouvre avec les librairies de Footprints disponibles. L’idéal est de pouvoir partager l’écran 
en deux parties, une avec Capture, l’autre avec Layout, pour les avoir tous les deux ensemble à l’écran, comme 
ci-dessous : 
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Rechercher alors dans les librairies du Library Manager, l’empreinte qui correspond le mieux à votre 
composant. Une fois trouvé, faire un copier-coller du nom entre le Library Manager et le property editor. Cela 
permet d’éviter ainsi les erreurs de frappe du nom de l’empreinte. Effectuer cette opération pour tous les 
composants du schéma, et remplir ainsi toute la colonne des PCB Footprint. Il est important d’apporter une 
attention particulière à cette opération, car il existe plusieurs empreintes avec des ordres de broches différents 
ou des noms de broches différentes (particulièrement pour les transistors, et pour les circuits intégrés) et si 
vous vous êtes trompés, ça ne fonctionnera pas !. S’il n’ a pas de concordances il faut utiliser la commande EDIT 
PART de CAPTURE pour mettre à jours les données de broches qui correspondent à celles qui figurent dans les 
empreintes. 
Après cette opération on doit avoir pour chaque composant du schéma un nom d’empreinte physique qui lui 
correspond. 

 

 
 
 

3.4- Création de la Netlist : 

 
Une fois fini, refermer la page du schéma, faire une sauvegarde, puis sélectionner la page, puis faire Tools-> 
Create Netlist, une nouvelle fenêtre s’ouvre, choisir l’onglet « Layout », cochez la case Run ECO to Layout, puis 
sélectionnez le bouton User Properties in inches (surtout pas en millimètres !) Puis vérifiez que le fichier Netlist 
(Netlist File) est bien sauvegardé dans votre espace de travail. 
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3.5- Création Nouveau Typon : 
 
Vous pouvez relancer Layout si vous l’aviez fermé, puis choisir File -> New. Une nouvelle fenêtre s’ouvre, pour 
vous demander le Fichier de Gabarit (Template File) qui est situé dans le répertoire : 
  

c:\Program Files\OrCAD\LAYOUT\DATA 
 

puis choisir le fichier _DEFAULT.TCH  pour faire un circuit imprimé en simple face avec des propriétés par 
défaut  
 

 
 

Puis maintenant, vous devez lui fournir le fichier Netlist que vous avez créé précédemment : 
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Puis on vous propose la sauvegarde de votre typon avec le nom du projet avec l’extension .MAX ainsi que le 
répertoire où vous voulez le mettre (de préférence dans votre espace de travail). Et faites Enregistrer. Une 
fenêtre de travail s’ouvre pour vous détailler l’importation du fichier, si tous se passe bien, la fenêtre se 
referme et vous avez le chevelu de votre circuit. Dans le cas contraire, Notez le composant en cause, et faites 
Cancel, quittez Layout et allez corriger le problème dans Capture. 
 

 
 
Sélectionnez le menu Options -> System Settings, puis mettre le paramètre Place Grid à 50 mils. Ne pas touchez 
aux autres paramètres et ne jamais se mettre en millimeters. Faites OK. 
 

3.6- Utilisation du DRC Box : 

 
La DRC Box est la zone entourée d’un cadre en pointillé, c’est la zone que LAYOUT surveille, pour vous (lui) 
éviter de faire des erreurs. Il ne faut pas la désactiver. 
Pour qu’elle ne vous pose pas de problèmes, il faut qu’elle englobe tous les composants et toute la carte. On 
peut donc la redessiner avec le menu View -> Zoom DRC/Route Box, puis cliquer en haut à gauche du cadre de 
DRC Box que vous désirez, restez appuyé en vous déplaçant vers le bas à droite du cadre voulu, quand c’est Ok, 
relâchez le bouton gauche de la souris.  
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3.7- Placement des composants : 
 
Il faut maintenant : 
Essayer de les placer comme sur le schéma structurel pour commencer ; 

 Mettre les connecteurs sur le bord de la plaque ; 

 Prévoir l’emplacement des composants imposés ; 

 Placer les composants de manière à avoir une carte la plus petite possible ; 

 Eviter d’avoir des places vides de composants ; 

 Avoir le moins de croisements de fils possibles ; 

 Prévoir la place de réglage pour les composants à régler ; 

 Prévoir les trous de fixations si besoin ; 

 Essayer de mettre les composants dans le même sens ; 
 
Il faut commencer par choisir l’outil Component Tool : Cliquer sur un composant, pour le prendre, le déplacer à 
l’endroit voulu (un appui sur la touche R permet de lui faire faire une rotation de 90°), et recliquer pour le 
lâcher ! Effectuer cette opération pour tous les composants. 
 

 
 

3.8- Tracé du contour du circuit imprimé : 

 
Pour tracer le contour de la plaque, il faut choisir l’outil Obstacle Tool : 
Se mettre dans le coin du cadre à dessiner puis faire un clique droit, puis New, puis dessiner le cadre (qui doit 
être à 50 mils des composants). Vérifier que le cadre est un Board Outline, et qu’il est sur le Global Layer / 
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Remarque : dans le cas où le circuit imprimé comporte un nombre imposant de composant, il est préférable de 
procéder à un placement semi automatique. Pour cela on commence par un placement manuel des 
composants critiques ( les que les connecteurs ). On définit le contour de la carte en dehors de la zone  
La DRC Box. On sélectionne ensuite les autres composants qui ne sont pas encore placés et on lance la 
commande de placement automatique pour ces composants :  
 
 

 
 
Le système procède alors à un placement automatique à l’intérieur du contour du circuit imprimé en 
respectant une stratégie de placement qui peut être personnalisée par la commande option->Placement 
Strategy 
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3.9-  Modification de la largueur des pistes : 

 
Il faut maintenant définir la largueur des pistes en fonction du courant qui passe dedans, par défaut, on 
prendra une piste de 20 mils à 40 mils pour un courant inférieur à 1.5A, sinon consulter l’annexe 1 ! 
Pour avoir la liste des connections et leurs caractéristiques, il faut aller dans le menu  

View ->DataBase Spreadsheet -> Nets une fenêtre s’ouvre avec les caractéristiques des nets du circuit : 

 

 
 

C’est la colonne Width qui nous intéresse, les 3 valeurs correspondent à la largueur minimum, de connexion, 
maximum  en  mils (milli inches = inches/1000). 
Il faudra modifier la largeur des Nets « Un par Un » en fonction des courants qui y circule. Quand vous avez fini, 
juste refermer la fenêtre avec la croix, puis ré ouvrir la fenêtre DESIGN. 
 

3.10-  Modification de la largueur des pastilles : 

 
Il faut maintenant vérifier que la largueur des pastilles est correct. On doit avoir des pastilles d’un diamètre de 
75 mils (minimum de 40 mils (1 mm)) pour pouvoir percer à 0,8 mm et qu’il reste un minimum de cuivre sur la 
pastille pour pouvoir faire la soudure. Il faut aller chercher l’outil pastille (Pin Tool) : 
Puis cliquez sur la pastille dont vous souhaitez changer le diamètre, puis le menu  
View -> Database Spreadsheet -> Padstacks (ou Shift T), la fenêtre de définitions des pastilles s’ouvre, et la 
pastille qui vous intéresse est sélectionnée en noir. 
Dans notre cas, on va configurer simultanément la largeur de toutes les pastilles de notre circuit imprimé à 75 
mils. Pour cela, il suffit de lancer la commande du menu Tool->Padstack->Select From Spreed Sheet et de 
configurer la couche Layer où se trouvent les pastilles à dimensionner et la largeur souhaitée : 
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On obtient alors la fenêtre suivante : 
 

 
 
On introduit ensuite les propriétés qu’on souhaite modifier pour les éléments qui ont été sélectionnés: 
 

 
 
 

3.11-  Modification de la largueur de perçage des pastilles : 
 
En utilisant la même procédure il faut changer la valeur du DRILL et du DRILLDWG (trou de perçage)  à 30 mils, 
pour un perçage à 0,8 mm.  

 

3.12- Vérification de la faisabilité : 

 
Pour savoir si votre circuit va être « routable facilement, vous pouvez avoir une identification des zones à 
risques. Allez dans le menu View -> Density Graph ->Fine. Une nouvelle fenêtre s’ouvre, qui vous indique en 
rouge les parties difficiles à router, en bleu les parties faciles : 
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Dans le cas où des zones rouges apparaissent, il faut revoir l’emplacement des composants pour éviter des 
zones de congestion lors du routage des pistes. 
 

3.13-  Routage des pistes : 

 
 

Routage Manuel : 
 
Pour commencer le routage des pistes, il faut choisir l’outil Add/Edit Route Mode : 
Cliquez sur une pastille, (du coté du départ du fil de chevelu), puis faire un clique gauche pour chaque 
changement de direction, jusqu’à la pastille d’arrivée. Si le chemin est assez direct, un appui sur la touche F 
permet de finir automatiquement le routage de la piste, mais sans garantie de respect des règles de routage. 
Sinon, pour finir le routage de la piste, clique droit « End Command ». 
 
 
A propos, les règles de routage sont : 
 

 Pas d’angle droit, 

 Faire les pistes les plus courtes possibles, 

 Evitez les angles trop longs, 

 Effectuer les croisements de préférence sur une pastille, 

 Ne pas faire arriver 2 pistes à moins de 90° sur une pastille, 

 Ne pas faire de boucles, essayer de router en étoile, 

 Laisser 1 pas au minimum par rapport au bord du circuit, 

 Respecter l’isolation entre pistes, s’il y a de fortes tensions, 
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Pour modifier une piste déjà routée, il vaut mieux utiliser l’outil Edit Segment Mode : Cliquez alors sur le 
segment de piste à modifier, puis le déplacer, et recliquez pour le placer. 
 

 
 

Routage Automatique : 
 
Dans le cas où le nombre de piste est assez important, il est préférable d’opter pour un routage automatique. 
Pour cela, il faut commencer par définir les couches sur lesquelles le routeur doit opérer ( par défaut 4 
couches : le couche TOP c’est-à-dire côté composants, la couche BOTTOM c’est-à-dire côté soudure plus deux 
couches internes ). Pour notre part, on ne va réaliser le routage que sur une seule couche : la couche BOTTOM. 
Pour cela, il faut lancer la commande du menu Option-> Route Strategies -> Route Layers : 
 

 
 
 
 

Dévalider ensuite le routage sur toutes les pistes sauf la piste BOTTOM : 
 



Page 20 
 

 
 

Lancer ensuite la commande de routage de toute la carte à partir de la commande de menu  
Auto->Autoroute->Board. 
Dans la plus part du temps on obtient alors un circuit imprimé routé à 100% :  
 

 
 

3.14 - Vérifications que toutes les pistes sont routées : 

 
Pour vérifier que vous n’avez pas oublié de router une piste cachée, allez dans le menu  
Auto ->Refresh -> Calculate Statistics, une fenêtre s’ouvre avec les caractéristiques de votre circuit, puis vérifiez 
que la ligne % Routed est à 100 % et que la ligne % Unrouted est à 0 %, et que la ligne % Partial est aussi à 0 %. 
Et que le nombre de Design Rule Errors est à 0 : 
 

 
 
Remarque : s’il reste des pistes non routée, il faut procéder à un routage manuelle de celles-ci. 
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3.15- Déplacer l’origine des mesures : 

 
Pour pouvoir obtenir des mesures faciles à interpréter, et avoir une impression correcte, il faut mettre le point 
d’origine (Datum) sur un coin du circuit.  
Pour cela, allez dans le menu tools -> Dimension -> Move Datum, puis faire un clique gauche pour le déposer 
sur le coin en bas à gauche du circuit : 
 

 
 
 

3.16- Effectuer une vérification du circuit : 

 
Avant d’imprimer le typon, il faut effectuer une dernière vérification, pour confirmer que nous n’avons pas fait 
d’erreurs de connections. Pour cela aller dans le menu Auto -> Design Rules Check. Une fenêtre s’ouvre avec 
différentes options, ne rien changer et faire OK. 
 

 
 

S’il n’y a pas d’erreurs, cette fenêtre est remplacée par une autre, vous informant que tout est OK : 
 

 
 
Sinon, ré importer la Netlist pour corriger les erreurs. 
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3.17- Faire un plan de masse : 

 
Un plan de masse permet de réaliser une bonne compatibilité électromagnétique vis-à-vis des perturbations 
électromagnétiques qui causent des signaux parasites qui sont néfastes pour le bon fonctionnement du 
système. 
Pour placer un plan de masse dans la couche BOTTOM il suffit de suivre la procédure suivante : 

 commande Obstacle tools 

 Sélectionner la bordure 

 Clic droit -> properties  

 Type : copper poor, 

 Width : 25 (mils), 

 Layer : Bottom, 

 Clearance : 50 (mils) isolation îste / plan de masse, 

 Net Attachement : 0 ( c’est à dire la masse GND ) 

 OK 

 Clic droit -> End Commande  
 

 
 

Après avoir réalisé ces commandes on obtient alors le résultat  suivant :  
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3.18- Impression du typon : 
 
Une fois que vous êtes sûr de vous, vous pouvez imprimer le typon sur calque ( un essai sur papier peut ne pas 
être superflu !) pour cela aller dans le menu Options -> Post Processing settings, une fenêtre s’ouvre avec les 
différentes faces de votre typon. Si vous êtes en simple face, seule la face BOTTOM, et la face AST (dessin des 
composants vu de dessus) ( En CMS, c’est la face SMT) vous intéresse. En Double face, il faut rajouter la face 
TOP. Ces faces doivent avoir le BATCH ENABLED à Yes. Dans notre cas, on ne va valider pour l’impression que la 
couche BOTTOM : 
 

 
 

Pour le modifier les paramètres relatives à l’impression de cette touche, il faut cliquer sur la la ligne qui vous 
intéresse pour la sélectionner, puis clique droit PROPERTIES, une fenêtre s’ouvre avec les différentes propriétés 
: 

 

 
 

Pour cette couche faire un clique droit sur le tableau précédent au niveau de la couche BOTTOM puis Run 
Batch, choisir la bonne imprimante, puis imprimer. 


